千家信息网

47、BGP配置实验之MED选路

发表于:2024-10-04 作者:千家信息网编辑
千家信息网最后更新 2024年10月04日,1、as-path选路解析属性传播范围默认值优先值方向备注weight本路由器本路由器32768,其他路由器0大值优先INCISCO私有Local preferenceAS内部100:边界路由器,通告
千家信息网最后更新 2024年10月04日47、BGP配置实验之MED选路

1、as-path选路解析

属性
传播范围
默认值
优先值方向
备注
weight本路由器本路由器32768,其他路由器0大值优先INCISCO私有

Local preferenceAS内部100:边界路由器,通告给IBGP邻居,告知如何离开本AS大值优先OUT
As pathAS之间短优先IN、OUT
MEDAS内部0:通告给EBGP,告知如何进入本AS小优先OUT

修改MED值的方法:



2、实验拓扑

3、基础配置

R1配置

interface Loopback0

ip address 1.1.1.1 255.255.255.0

interface Serial0/0

ip address 13.1.1.1 255.255.255.0

interface Serial0/1

ip address 14.1.1.1 255.255.255.0

router ospf 110

router-id 1.1.1.1

log-adjacency-changes

network 1.1.1.0 0.0.0.255 area 0

network 14.1.1.0 0.0.0.255 area 0

router bgp 4

no synchronization

bgp router-id 1.1.1.1

neighbor 4.4.4.4 remote-as 4

neighbor 4.4.4.4 update-source Loopback0

neighbor 4.4.4.4 next-hop-self

neighbor 13.1.1.3 remote-as 3

no auto-summary


R2配置

interface Loopback0

ip address 2.2.2.2 255.255.255.0

interface Serial0/1

ip address 23.1.1.2 255.255.255.0

interface FastEthernet1/0

ip address 24.1.1.2 255.255.255.0

router ospf 110

router-id 2.2.2.2

network 2.2.2.0 0.0.0.255 area 0

network 24.1.1.0 0.0.0.255 area 0

router bgp 4

no synchronization

bgp router-id 2.2.2.2

neighbor 4.4.4.4 remote-as 4

neighbor 4.4.4.4 update-source Loopback0

neighbor 4.4.4.4 next-hop-self

neighbor 23.1.1.3 remote-as 3

no auto-summary


R3配置

interface Loopback0

ip address 3.3.3.3 255.255.255.0

interface Loopback1

ip address 33.33.33.33 255.255.255.0

interface Serial0/0

ip address 13.1.1.3 255.255.255.0

interface Serial0/1

ip address 23.1.1.3 255.255.255.0router bgp 3

no synchronization

bgp router-id 3.3.3.3

network 3.3.3.0 mask 255.255.255.0

network 33.33.33.0 mask 255.255.255.0

neighbor 13.1.1.1 remote-as 4

neighbor 23.1.1.2 remote-as 4

no auto-summary


R4配置

interface Loopback0

ip address 4.4.4.4 255.255.255.0

interface Serial0/1

ip address 14.1.1.4 255.255.255.0

interface FastEthernet1/0

ip address 24.1.1.4 255.255.255.0

router ospf 110

router-id 4.4.4.4

network 4.4.4.0 0.0.0.255 area 0

network 14.1.1.0 0.0.0.255 area 0

network 24.1.1.0 0.0.0.255 area 0

router bgp 4

no synchronization

bgp router-id 4.4.4.4

network 4.4.4.0 mask 255.255.255.0

neighbor 1.1.1.1 remote-as 4

neighbor 1.1.1.1 update-source Loopback0

neighbor 2.2.2.2 remote-as 4

neighbor 2.2.2.2 update-source Loopback0

no auto-summary


4、默认选路

根据BGP选路原则第十条可以知道,R3到达4.4.4.0/24默认经过R1。

5、修改MED值让R3访问4.4.4.0/24的时候从R2经过

R1配置

ip prefix-list 1 seq 5 permit 4.4.4.0/24

route-map MED permit 10

match ip address prefix-list 1

set metric 10

route-map MED permit 20

router bgp 4

neighbor 13.1.1.3 route-map MED out

0